Just a few days ago I was alarmed on the forum that many users of AVChat started getting the error in the title out of the blue without the chat webmasters doing anything.

After a quick investigation we had found the culprit.

It seems Adobe has modified something in their latest Flash Player Update (11.1.102.62).

August 2012 update: it seems the issue also shows up in FP 10.3.183.20 released on 06 August 2012. teh patches at the bottom do not fx the issue for FP 10.3.183.20 .

They modified the contents of the pageUrl variable sent by Flash Player when it connects to a media server like FMS, Red5 or Wowza.

In FP 11.1.102.55 (released on November 7th, 2011) pageUrl looked like this: http://avchat.net/demos/avchat30/
In FP 11.1.102.62 (released on February 15th, 2012, the one thats causing the issue) pageUrl is truncated and looks like this: http://avchat.net

Strangely enough this modification/problem exists only in Firefox ( on both PC and MAC).

This shorter pageUrl flips our domain checking mechanism resulting in end users getting the error in the title when trying to connect.

To fix the issue we have compiled some new media server files (Red5, FMIS, Wowza) for the latest build of AVChat, 1418 and attached them to this blog post together with patching instructions.

We will compile such patches for both older versions of AVChat and other software like our HDFVR video recorder .

FLVAR for Red5 and FMIS, SimplChat and AVConference do not need patching.

============== AVChat 3 build 1418 patches below============

To fix the error when using AVChat 1418 and FMIS media server:

1. Download this archive: zip archive containing new main.ase file for FMIS
2. Extract the contents of the attached archive, it contains a new main.ase file
3. Replace your old main.ase file in FMS/applications/avchat30/ with the new one in the attached archive
4. Restart the media server OR reload the avchat30 application using the FMS management console/FCS application inspector
5. Done

To fix the error when using AVChat 1418 and Red5 media server:

1. Download this archive: zip archive containing new Application.class file for Red5
2. Unpack the attached archive, it contains a new Application.class file
3. Replace your old Application.class file in Red5webappsavchat30WEB-INFclassesavchat3 with the new one
4. Restart Red5
5. Done

To fix the error when using AVChat 1418 and Wowza media server:

1. Download this archive: zip archive containing new avchat3.jar file for Wowza
2. Unpack the attached archive, it contains a new avchat3.jar file
3. Replace your old avchat3.jar file in Wowzalib with the new one in the attached archive
4. Restart Wowza
5. Done

============== AVChat 3 build 1252 patches below============

To fix the error when using AVChat 1252 and Red5 media server:

1. Download this archive: zip archive containing new Application.class file for Red5
2. Unpack the attached archive, it contains a new Application.class file
3. Replace your old Application.class file in Red5webappsavchat30WEB-INFclassesavchat3 with the new one
4. Restart Red5
5. Done

============== AVChat 3 build  1198 patches below============

To fix the error when using AVChat 1198 and FMIS media server:

1. Download this archive: zip archive containing new main.ase file for FMIS
2. Extract the contents of the attached archive, it contains a new main.ase file
3. Replace your old main.ase file in FMS/applications/avchat30/ with the new one in the attached archive
4. Restart the media server OR reload the avchat30 application using the FMS management console/FCS application inspector
5. Done

To fix the error when using AVChat 1198 and Red5 media server:

1. Download this archive: zip archive containing new Application.class file for Red5
2. Unpack the attached archive, it contains a new Application.class file
3. Replace your old Application.class file in Red5webappsavchat30WEB-INFclassesavchat3 with the new one
4. Restart Red5
5. Done

============== AVChat 3 build  960 patches below============

To fix the error when using AVChat 960 and Red5 media server:

1. Download this archive: zip archive containing new Application.class file for Red5
2. Unpack the attached archive, it contains a new Application.class file
3. Replace your old Application.class file in Red5webappsavchat30WEB-INFclassesavchat3 with the new one
4. Restart Red5
5. Done

============== HDFVR patches below============

To fix the error when using HDFVR (any build) and FMIS media server:

1. Download this archive: zip archive containing new main.ase file for FMIS
2. Extract the contents of the attached archive, it contains a new main.ase file
3. Replace your old main.ase file in FMS/applications/hdfvr/ with the new one in the attached archive
4. Restart the media server OR reload the hdfvr application using the FMS management console/FCS application inspector
5. Done

To fix the error when using HDFVR (any build) and Red5 media server:

1. Download this archive: zip archive containing new Application.class file for Red5
2. Unpack the attached archive, it contains a new Application.class file
3. Replace your old Application.class file in Red5webappshdfvrWEB-INFclassesVideoRecorder with the new one
4. Restart Red5
5. Done

To fix the error when using HDFVR (any build) and Wowza media server:

1. Download this archive: zip archive containing new hdfvr.jar file for Wowza
2. Unpack the attached archive, it contains a new hdfvr.jar file
3. Replace your old hdfvr.jar file in Wowzalib with the new one in the attached archive
4. Restart Wowza
5. Done

============== FLVAR patches below============

To fix the error when using FLVAR (any build) and Wowza media server:

1. Download this archive: zip archive containing new audiorecorder.jar file for Wowza
2. Unpack the attached archive, it contains a new audiorecorder.jar file
3. Replace your old audiorecorder.jar file in Wowzalib with the new one in the attached archive
4. Restart Wowza
5. Done

Update 9th of March 2012:

Adobe just released Flash Player 11.1.102.63 for PC and 11.1.102.64 for Mac on March 4.

This update does not fix the initial issue that caused the “Connection rejected error” introduced in Flash Player 11.1.102.62.

22 thoughts on ““Connection rejected: You did not connect comming from a licensed domain” caused by latest Flash Player update (11.1.102.62)

  1. MacLean says:

    “comming” is misspelled. The correct spellling is “coming”.
    You would have been alarmed sooner if your forums were working.
    Wish I could bill you for my time over this.
    It’s all your licensing issues. Read the domain and nothing else there won’t be a problem…

  2. Sean says:

    I need the fix for build 1198, I don’t know why my previous request was deleted.

    1. Octavian says:

      What media server?

  3. Michael says:

    Awesome; patch works great. Thanks for the quick update.

  4. Austin says:

    I need a patch update for 1198 on a red5 server.

  5. Sean says:

    1198 on a red5 server.

  6. Octavian says:

    Application.class file for AVChat 1198 on Red5 added

  7. Austin says:

    I’ve done what is requested and now I’m getting a different error message which reads “connection failed, media server might be down or firewall might be blocking the connection”….

    HELP!

  8. Octavian says:

    Please contact us at support@avchathq.com with a direct link to where you have it installed.

  9. Dennis says:

    Need a patch for build 1182. Upgrading to the latest version is not an option. Tried that once and it caused problems with long delays on messages in the chat.

  10. Octavian says:

    Dennis what media server?

  11. Octavian says:

    Try using the patch file for AVChat 3 build 1198 .

    Also on 4 March Adobe released a new version of Flash Player (11.1.102.63) which fixes the initial issue introduced in the previous version (11.1.102.62) so there is no need for the patch anymore if Firefox users upgrade to the latest version of Flash Player. Actually this new version of Flash Player does not fix the issue.

  12. Max says:

    Hello Ocatavian!

    I have tried patch for 1198 … – but no luck… any advise how to fix it on 1182 build?

    1. Octavian says:

      Max what media server are you using?

  13. red5 server says:

    It also can handle provided things, and VP6. These things can easily be reinforced by Red5 server. Licensed domain and the latest flash player also such a good thing.

  14. Alec says:

    Have tried to apply the patch twice to our application and it has not made a difference. Support are just advising to apply the patch.

    I have also upgraded the version to 1521 hoping that this might not have the same problem as there is no patch for it. But still the problem exists.

    I have done a “whereis red” on my linux box and there is only one instance of red5. The server has been stopped and started multiple times, but still no joy.

    Any assistance?

    Alec

    1. Octavian says:

      Alec have you tried contacting our tech support at support@avchathq.com ?

  15. James Jones says:

    Hi,

    Having the same issue with build 800
    Version: 11.8.800.96
    with Red5

    Help, please ?

    Thanks,

    1. Octavian says:

      Please contact our support at support@nusofthq.com and send us a direct link to where this happens so that we can investigate.

Leave a Reply to James Jones Cancel reply

Your email address will not be published. Required fields are marked *